Vista im Selbstversuch (III)

“Das Leben, wie es sein sollte” – damit macht ein bekannter Hersteller einer ebenfalls bekannten Limonade Werbung. Ein ähnliches Gefühl habe ich heute auch bei meinem Vista gehabt.

Heute war nämlich der große Spieletag. Solitär, eines der mitgelieferten Windows-Spiele, die im Übrigen alle neu gemacht wurden, hatte es mir besonders angetan. Und schwupps, purzelten die Rekorde. Letzter Stand ist etwas mehr als 10000 Punkte; jetzt haben die Mitbenutzer meines Rechners (ebenfalls Vista-Solitär-Junkies) erst einmal was zu tun, deren Rekord war nämlich bei 8514. Die anderen Bestwerte von heute waren alle von mir:
solitar
Doch das war noch nicht alles. Im Rahmen der GamePorts-Serie “Heute vor zehn Jahren” stehen noch ganze zwei Spiele aus. Da wäre zum einen Fallout (1) von 1997 zu nennen und zum anderen Grand Theft Auto (1), ebenfalls von 1997. Während es bei GTA nicht ganz so verwunderlich ist, dass es ohne Probleme läuft (schließlich wurde es ja vor kurzem im Zuge einer kostenlosen Veröffentlichung von Rockstar Games überarbeitet), ist es beim wirklich zehn Jahre alten Ur-Fallout schon so etwas wie ein kleines Wunder, dass es läuft. Vor allem, und das ist bei Vista das erste Mal bei einem NT-basierten Windows, läuft Fallout ohne Kompatibilitätsmodus – im Gegenteil: Wird der Kompatibilitätsmodus eingeschaltet (sodass beispielsweise Windows 98/Me emuliert wird), gibt es Bildfehler. Einzig der Taskmanager sollte geschlossen sein, während das Schätzchen gespielt wird, denn durch dessen regelmäßige Aktualisierung der Daten scheint Fallout ganz nervös zu werden und macht spontanerweise den Bildschirm schwarz, will man wieder etwas sehen, muss man dann über jeden Pixel mit dem Mauszeiger fahren, doch nur wenige Sekunden später fängt derselbe Spaß von vorn an. Eine weitere Überraschung war Pro Pinball: Timeshock!, das wir aber schon getestet haben. Das lief unter Windows XP nur ordnungsgemäß, wenn der neuste Patch installiert war und das Spiel im Kompatibilitätsmodus für Windows 95 oder 98/Me betrieben wurde. Die Sache mit dem Patch ist dieselbe, nur den Kompatibilitätsmodus sollte man ausgeschaltet lassen, sonst kommen, erstaunlicherweise, dieselben Bugs, die man im Windows XP ohne Kompa-Modus hatte (nämlich dass die Flipper entweder zu spät oder gar nicht reagieren). Ebenfalls sollte der Zappelphilipp von Taskmanager ausgeschaltet werden, sonst ruckelt die Pinball-Simulation. Aber es läuft!

Aber die Glücksgefühle hören an dieser Stelle noch nicht auf. Auch der Firefox (der bei mir Minefield heißt, weil ich eine tagesaktuelle Build verwende) benimmt sich gegenüber Links aus Windows-Programmen (z.B. Instant-Messengern) so, wie es von ihm als Standardbrowser erwartet wurde. Hierbei ist zu sagen, dass das, was man gerne mal bei Google findet (weil es gut im Rank liegt) falsch ist. Nein, in Windows Vista ist die iexplore.exe NICHT fest verdrahtet mit Links aus Programmen! Viel mehr ist es so, dass im Vista ein Standardbrowser nicht gleich Standardbrowser ist. Allerdings muss ein Browser (und dabei ist es egal, ob es vielleicht auch Opera oder ein ganz anderer sein soll) unbedingt installiert werden. Vorher gibt es nichts mit Standardbrowser. Nachdem er installiert ist, wird er fragen, ob er sich als Standardbrowser im System verewigen darf. Die Antwort auf diese Frage tut aber nichts zur Sache, es werden hier lediglich HTML-Dateien verknüpft und festgelegt, dass ein HTTP-Protokoll mit eben jenem Browser geöffnet werden sollte. Aber die meisten Windows-Programme stört das unter Windows Vista wenig. Doch auch hier gibt es eine Abhilfe. Stellen Sie erst einmal sicher, dass, aufgrund der schnellen Erkennung, kein Desktop-Icon Ihres favorisierten Browsers vorhanden ist. Gehen Sie dann ins Startmenü und zu “Standardprogramme”. Es öffnet sich ein Fenster, hier wählen Sie “Programmzugriff und Computerstandards festlegen”. Falls der Punkt noch nicht gesetzt ist, setzen Sie ihn bei “Benutzerdefiniert” und klicken Sie auf den Doppelpfeil in derselben Zeile. Klicken Sie jetzt bei “Wählen Sie einen Standardbrowser aus” auf Ihren favorisierten Browser, also z.B. Firefox oder Opera und anschließend auf “OK”. Wenn jetzt auf dem Desktop eine Verknüpfung zum ausgewählten Browser erstellt wurde, dürfte alles geklappt haben. Nun müssen nur noch Programme, die Links beinhalten (wie Instant-Messenger) neu gestartet werden. Der Einfachkeit halber kann auch der gesamte Computer neu gestartet werden. Danach dürften alle Links in Ihrem favorisierten Browser aufgerufen werden.

Vista im Selbstversuch (II)

Heute: Wie Winamp stabil wurde, der Scanner wieder scannte und ich die Lage einschätze.

Fangen wir beim Scanner an. Bei Canon ist noch alles beim Alten geblieben, kein neuer Treiber und der alte funktioniert noch immer nicht. Doch da fiel der Blick in eine der vier Ecken meines Zimmers, wo tatsächlich noch ein älterer Aldi-Scanner steht. Dieser sollte eigentlich aufgrund seines Alters und der Geschwindigkeit (er ist vergleichsweise langsam) in Rente geschickt werden. Aber da ihn keiner haben wollte, stand er da einsam herum. Eigentlich eher aus Spaß habe ich dann mal bei Medion geschaut, wie es denn mit Vista-Treibern aussieht. Und tatsächlich! Medion bietet wirklich seit Februar 2007 Treiber für beide Vista-Architekturen (32- und 64-bit) an. Im Gegensatz zu den Canon-Treibern wurden diese Treiber extra für Vista aktualisiert (denn einen XP x64-Treiber gab es nicht). Die Folge: Der Treiber funktionierte auf Anhieb genau so, wie man es erwartet hätte. Daher nimmt jetzt erstmal der Canon-Scanner den Platz in der Ecke meines Zimmers ein.

Winamp, mein Lieblingsmediaplayer, hatte auch das eine oder andere Problem unter Vista. Eigentlich nur das eine Problem, es war ein Programmabsturz, und zwar immer an der selben Stelle. Vista gab dann in etwa das aus:

Problemsignatur:
Problemereignisname: APPCRASH
Anwendungsname: winamp.exe
Anwendungsversion: 5.3.5.1305
Anwendungszeitstempel: 4648e17d
Fehlermodulname: ntdll.dll
Fehlermodulversion: 6.0.6000.16386
Fehlermodulzeitstempel: 4549bdc9
Ausnahmecode: c0000005
Ausnahmeoffset: 00062086
Betriebsystemversion: 6.0.6000.2.0.0.768.3
Gebietsschema-ID: 1031
Zusatzinformation 1: 93e7
Zusatzinformation 2: e5c5848a537e479b49aeb06539ab262d
Zusatzinformation 3: 51cf
Zusatzinformation 4: 0d448cf76cde3f622886745af1d32ecf

Des Rätsels Lösung ergab sich dann im Winamp-Forum. Einfach mal die Media-Library leeren. Seither (gestern abend) keine Abstürze mehr.

Zur Einschätzung bisher. Also es ist ja so, dass man im Vorfeld vieles gehört hat, was gar nicht gut klang. Aber mit etwas Einarbeitung stellt sich recht fix heraus, dass davon nicht viel (Sichtbares) übrig geblieben ist. Viele der neuen Funktionen haben durchaus ihre Daseinsberechtigung. Auch das neue Speicher-Management macht das System in der täglichen Arbeit angenehm schnell, auch wenn der erste Blick in den Taskmanager eine leichte Gänsehaut verursacht, wenn von satten 2 GiB RAM mal grade 5 MiB frei sind. Aber das merkt man in der täglichen Arbeit so gut wie gar nicht, im Gegenteil, Anwendungen reagieren zum Teil wesentlich schneller. Allerdings bleibt auch festzuhalten, dass Vista oft zu viel des Guten will. So z.B. der Windows-Defender. Eigentlich eine schöne Sache, aber er läuft dauerhaft im Hintergrund mit und meldet alles, was ihm auffällt (und das ist nicht wenig), dem Systemprotokoll. Auch die Benutzerkontenkontrolle ist nicht ganz das, was sie hätte sein sollen. Sie fragt bei sehr vielen Ereignissen nach, ob der Anwender das denn wirklich mit priviligierten Rechten tun möchte (da man ja normal als eingeschränkter Benutzer arbeitet), aber nur, wenn die entsprechende Anwendung das auch so vorsieht. Wenn nicht, dann gibt es “die nächst beste” Fehlermeldung, die z.T. nicht wirklich auf das eigentliche Problem hindeutet.
Sicherlich, das eine oder andere könnte vielleicht besser gelöst werden, aber insgesamt ist es so, dass das Treiberproblem wohl das größte Hindernis ist – ist selbiges überwunden, zeigt sich Vista erstaunlich kompatibel (softwareseitig) und auch recht fix. Allerdings sollte es schon ein einigermaßen starker Rechner sein – mit einer Grafikkarte, die kein DirectX9 kann, funktioniert Aero nicht und 1 GiB RAM sollte es auch sein, damit die neue Speicherverwaltung ihre Vorteile ausspielen kann.

Vista im Selbstversuch (I)

Hier nun erste Ergebnisse des Vista-Selbstversuchs. Vorsicht, es könnte etwas länger werden. Wahrscheinlich wird es diese Art Berichterstattung nicht jeden Tag geben, wahrscheinlich auch nicht immer so lang wie heute. Aber nach einer “Clean”-Installation gibt es nun mal viel zu erzählen.
Fangen wir bei der Hardware an. Diese ist halbwegs aktuell, ein Asus A8N32-SLI-Mainboard mit einem Opteron 165 (2x 1,8 GHz) mit 2 GiB RAM und einer GeForce 7900 GT. Dazu zwei Seagate-Festplatten, eine Hauppauge-TV-Karte und ein Sound Blaster Live! Value. Als optisches Laufwerk dient ein LG-DVD-Brenner. Insgesamt halbwegs aktuelle Hardware (ok, bis auf die Soundkarte vielleicht). Extern geht es weiter mit 2 HP-Druckern (ja aus Sicht der Tintenflaschenökonomie sind es 2) und ein Canon Scanner (CanoScan 3200F). Dieser Rechner, wie auch sein Vorgänger (welcher jetzt als Server arbeitet), kannte Zeit seines Lebens (also seit Ende Mai) nur das Windows XP Professional Betriebssystem, das auf meinen Rechnern schon sehr, sehr lange zum Einsatz kommt, genauer gesagt fast seit Verkaufsstart und eigentlich so gut wie immer eine gute Figur abgegeben hat. Das mag daran liegen, dass sich Windows 2000 zuvor schon etabliert hat und die Änderungen in XP nicht allzu groß ausfallen, aber das ist dem Konsumenten ja egal. Auf jeden Fall bleibt festzuhalten, dass Microsoft nach satten fünf Jahren tatsächlich ein neues Betriebssystem zur Marktreife (zumindest ist die Marketing-Abteilung davon überzeugt) gebracht hat. Da aufgrund meines “Doppellebens” bei GamePorts über kurz oder lang ohnehin kein Weg an Vista vorbeiführen wird (Stichwort DirectX10), habe ich jetzt schon mal angefangen, mich mit dem neuen Betriebssystem bekannt zu machen. Ich habe mich hierbei für eine saubere Installation (also mit vorherigem Formatieren der Windows-Partition) entschieden, weil erfahrungsgemäß ein Update von einer Windows-Version auf eine neuere nicht (immer) zufriedenstellend funktioniert.

09:45 war es dann soweit, das Backup aller halbwegs relevanten Sachen (eigentlich der gesamten Windows-Partition :D) war abgeschlossen und der Boot von der Vista-DVD kann beginnen. Hierbei fällt auch schon die erste Neuerung auf. Die Vista-Installation findet so gut wie gar nicht mehr im Textmodus statt, alles wird stattdessen schick im Grafikmodus präsentiert. Nach der Spracheingabe möchte Vista gerne die Seriennummer wissen. Seit dieser Windows-Version entscheidet einzig und allein diese Nummer, was installiert wird (welche Edition, welches Lizenzmodell [Update, Retail oder Systembuilder]), die DVD ist also praktisch neutral. Wird keine Seriennummer eingegeben, kann sich der Anwender frei aussuchen, welche Edition von Vista er 30 Tage lang testen möchte, in dem Fall wird nämlich eine Testversion installiert. Ich habe an dieser Stelle ein Windows Vista Home Premium (Systembuilder) in der 32-bit Version zur Verfügung. Das hat  diverse Gründe. Einmal ist die Home Premium-Version für den Hausgebrauch und fürs Spielen absolut ausreichend. Features wie die Dateisystemverschlüsslung mögen für manche Zielgruppen vielleicht nützlich sein, ich habe sie noch nie eingesetzt. Außerdem ist diese Version auch relativ erschwinglich (die Systembuilder-Version ohnehin, dafür gibts aber keinen Support von Microsoft!).
Außer dem wirklich sehr gut gelungenen Festplatten-Tool, mit dem sich Partitionen verwalten und formatieren lassen, bietet der Installer eher wenig Auswahlmöglichkeiten. Die längste Zeit darf der gespannte Anwender dann den Installationsstatus bewundern.

Zirka 20 Minuten später ist die Installation abgeschlossen und Vista möchte wissen, wie der Hauptbenutzer heißt und wo der Rechner zum Einsatz kommt. Anschließend wird noch “die Leistungsfähigkeit des Computers” ermittelt und damit ist die Installation auch schon abgeschlossen. Der Spaß kam aber noch, nämlich als es um die Treiber ging. Wer aktuelle, aber nicht brand-neue Hardware in seinem Rechner stecken hat, darf sich prinzipiell erst einmal freuen. Hier läuft Vista relativ flüssig und hat auch einigermaßen passende Treiber. Beispielsweise war ich direkt nach der Installation in der Lage, mit einem Browser meiner Wahl ins Internet zu gehen. Vista hat den nVidia-OnBoard-Netzwerkanschluss gefunden und korrekt konfiguriert. Doch bei genauerem Hinsehen fehlte der Sound. Hierfür hatte Vista anscheinend keinen Treiber. Aber da kann Windows-Update, welches nach sechs Monaten, die Vista bereits zu haben ist, schon 70 MB an Sicherheits- und sonstigen Updates anbietet, weiterhelfen. Über diese Funktion wurde auch ein Sound-Treiber für den SoundBlaster Live! Value bereitgestellt. Allerdings war der alles andere als funktionierend, der Sound klang sehr übersteuert. Lösung des Problems: Sound fast auf 0 stellen und am Verstärker aufdrehen. Übersteuerung war weg, aber dafür das typische Brummen des Verstärkers gut zu hören. Tante Google hatte dann aber eine gute Idee. Man solle sich den vier Jahre alten, aktuellsten SoundBlaster Live!-Treiber für Windows XP herunterladen, ihn extrahieren und Windows sagen, es solle doch lieber diesen Treiber installieren. Bingo! Sauberer Sound und kein Übersteuern mehr. Da der mitgelieferte Treiber aus Windows XP Ähnliches konnte, ist es fraglich, warum der Vista-Treiber von Windows-Update das nicht auch hinbekommt.

Die Installation der Chipsatz- und Grafiktreiber lief problemlos – etwas Anderes wäre auch sehr enttäuschend gewesen, sind doch eben jene Treiber extra für Vista veröffentlicht worden. Auch der Treiber der TV-Karte war kein Hindernis, hier lief auch alles wie geschmiert. Drucker sowieso, diese Treiber gabs ja bereits auf der Vista-DVD. Aber dann der Scanner. Laut Herstellerwebseite (zumindest auf der englischen, auf der deutschen findet ein Support seit ~2004 nicht mehr statt, hat man den Eindruck) liefe der XP-Treiber auch unter 32-bit Vista. Also installiert, Scanner angeschlossen, Vista findet “CANOSCAN 3200F” – prima. Ins Grafikprogramm, Scannen via Twain – Fehlanzeige. Der Treiber meint, der Scanner wäre nicht angeschlossen. Super. Wenn jemand eine Lösung für dieses Problem hat, ich bin offen für alles.

Kommen wir nun zum wirklich Wichtigen, Browser und Mailclient. Ich hatte es mir beim Mailclient so konfiguriert, dass die E-Mails selber auf meiner Datenplatte (die zweite Festplatte) abgelegt werden. Das hat den Vorteil, dass die Windows-Platte nicht mit inzwischen 4 GiB Post aus nahezu zehn Jahren eMails belastet wird. Tja, leider verwehrt uns Vista diesen Kunstgriff. Grund: Unter Standardeinstellungen ist es einem Programm nicht erlaubt, außerhalb seines eigenen Ordners und seinem “Anwendungsdaten”-Ordner Daten zu bearbeiten oder zu erstellen. Normalerweise hätte hier also eine Bestätigung der Benutzerkontenkontrolle kommen müssen, stattdessen kommt aber eine halbwegs irreführende Meldung, dass die Dateien nicht exklusiv lesbar sind, ich solle doch bitte schauen, ob nicht ein anderes Programm bereits zugreift. Lösung des Problems war das Deaktivieren der Benutzerkontenkontrolle. Das hat außerdem den Vorteil, dass nicht für wirklich jede “tiefere” Aktion eine Bestätigung notwendig wird. Der Firefox hingegen läuft ausschließlich in seinem Anwendungsdaten-Ordner. Daher hier keinerlei Probleme.

Auf den ersten Blick scheinen auf jeden Fall die akut gebrauchten Anwendungsprogramme und meine Lieblingsspiele (derzeit z.B. GTA3 und Half Life2 Deathmatch) zu funktionieren. Aufgrund des damit verbundenen Aufwands werd ich deshalb, sofern es keine wichtigen Gründe erfordern, wohl nicht zu XP zurückwechseln – denn, und darauf bin ich noch gar nicht eingegangen, die AERO-Oberfläche von Vista sieht absolut phantastisch aus, das sollte nicht außen vor bleiben.
Wie dem auch sei, ich werde den Rechner jetzt auf jeden Fall erst einmal herunterfahren – und morgen heute gehts dann weiter im Programm.

Das Browserkarusell dreht sich

Was macht man an so langweiligen Tagen wie dem heutigen? Man schaut Formel 1 😛 Und nachdem die vorbei ist? Hm… Man könnte Browser testen. Eine gute Idee 😀 So tat ich das heute – der große Browsertest der Internetbegleiter für Windows. In den Hauptrollen: Mozilla Firefox 3.0 Alpha, Opera 9.21, Safari 3.0.2, Internet Explorer 7. Ich hoffe ich habe keinen vergessen. Aber von den „echten“ Browsern (sprich die, die ihre eigene Engine etc. mitbringen) gibts afaik nur die o.g.

Den Anfang soll mal der Internet Explorer 7 machen.
Respekt. Ca. 4 Jahren nach seinen Konkurrenten hat er es auch gelernt mit Tabs umzugehen. Aber das wars auch schon fast. Die betont minimalistische Oberfläche wirkt, wie ich finde, viel zu unübersichtlich. Außerdem gibt es keinen eingebauten Werbefilter (und auch keiner, der mir bekannt wäre, der sich leicht nachrüsten ließe). Also überspringen wir den Kandidaten mal ganz schnell. Außerdem hat er ja ohnehin schon den größten Marktanteil auf Windows-Rechnern – und Standard ist langweilig 😀

Weiter gehts mit dem Newcomer Safari für Windows.
Der sollte ursprünglich die Mozilla-Gecko-Engine bekommen, doch dann kam alles anders und Apple entschied sich lieber für die KHTML-Engine aus dem KDE-Browser Konqueror. Immerhin: Durch diese Entscheidung wurde die Engine sehr schnell ziemlich ausgereift, was man jetzt auch unter Windows betrachten darf. Weniger schön ist, dass Besitzer eines nicht-englischen Windows-Systems bis zur dritten Beta-Version so gut wie ausgesperrt waren von dem Programm. Wie dem auch sei. Was mir aber so gar nicht gefällt, ist der Skin vom Safari-Browser. Nach jahrelangen Windows-Erfahrungen ist die Mausrichtung nach ganz oben rechts schon sowas ähnliches wie ein Reflex für das Schließen eines maximierten Fensters. Aber nicht mit Safari. Nicht genug, dass bei einem solchen Klick bei Safari nichts passiert, weil der X-Knopf nicht dort zu treffen ist, nein, das dahinterliegende Programm wird stattdessen geschlossen. Auch hier gilt dasselbe wie beim Internet Explorer – der Safari ist ein Browser, aber kaum etwas mehr. Auch hier fehlt ein Werbeblocker, beispielsweise. Also legen wir auch diesen Browser bei Seite.

Unser nächster Probant ist der Firefox in einer Nightly-Build der Version 3.0
Dieser Browser durfte bei mir schon recht lange seine Runden drehen. Durch sein Adblock-Plugin haben wir die erste Hürde schon überwunden *g* Jedoch ist es nach drei Jahren der exessiven Firefox-Benutzung Zeit, mal etwas anderes zu probieren.
…und dieses andere ist…

…der Opera-Browser!
Opera-Anwender, und je länger desto „schlimmer“, schwärmen schon lang von „ihrem“ Browser – ähnlich wie „absolut überzeugte“ Firefox-Anwender. Aber wie sieht es aus, wenn man versucht, einfach mal Opera auszuprobieren? Also zuerst einmal bleibt festzuhalten, dass der Firefox beispielsweise sinnvollere Standardeinstellungen hat, beispielsweise bei den Cache-Einstellungen. Denn dieses ist beim Opera recht ausgereift, z.T. zu ausgereift. Denn der Browser nimmt, zumindest über weite Strecken, an, dass eine gleiche URL innerhalb einer kurzen Zeit (z.B. 5 Minuten) auch noch dengleichen Inhalt hat. Jedoch wissen es Forengänger besser, dem ist häufig nicht so. Doch wenn die Einstellungen ersteinmal an die eigenen Bedürfnisse angepasst sind, dann fängt Opera an, mit seinen Stärken zu glänzen. Er ist ein Browser, der unerwartet viele Funktionalitäten bietet, beispielsweise ein kompletter E-Mail-Client. Auch die Möglichkeit, Web-Inhalte (z.B. Werbung) zu blockieren, existiert von Haus aus. Dabei ist der Browser aber auch sehr schön schnell, vor allem beim Start. Weniger schön ist, dass die Symbolleisten nicht wirklich flexibel sind. Beispielsweise die „Persöhnliche Leiste“, die ich für sehr oft besuchte Bookmarks missbrauche. Die grundsätzliche Position (oben, unten, links, rechts) ist zwar anpassbar, aber, zumindest habe ich es noch nicht gefunden, es ist unmöglich, die Reihenfolge der Leisten zu verändern (z.B. die „Persöhnliche Leiste“ unter die Tab-Leiste soll). Das einzige aber, was richtig nervend ist, ist der Hotkey für den „accesskey“ (also z.B. in Foren einen Beitrag abschicken mit ALT+S, wobei das S im HTML-Quellcode festgelegt werden kann). Der hat im Opera-Browser tatsächlich den sensationellen Hotkey von SHIFT+ESC+S (wobei S auch hier frei wählbar im Quellcode ist). Na prima. Wer hat sich denn das ausgedacht? Naja, wenn jemand weiß, wie man dieses Verhalten vielleicht doch ändern kann, der kann sich ja in den Kommentaren verewigen 🙂

Auf jeden Fall nehm ich jetzt erstmal den Opera-Browser – um mal etwas Neues zu probieren. Mal sehen, wie lang ich das aushalte 😀