Sätze, die von mir hätten sein können müssen (II)

Kurz vorab: Wir hatten letztes Semester einen Helferling in einem mathematischen Fach, der sah etwas unvorteilhaft aus (um es mal nett auszudrücken). Es war ein herzensguter Mann, aber er sah halt etwas heruntergekommen aus.

Heute, nach einem etwas chotischen und hektischen Analysis-Seminar wurde dieser Sachverhalt wieder aufgegriffen…

A> Was meinst du wo sie den Typen her hatten?
B> Den haben die sich aus Integrationsgrenzen gebastelt

Sätze, die von mir hätten sein können müssen

Neulich in der C-Vorlesung – der werte Professor erklärt so, wofür man Pointer (aka „Zeiger“) missbrauchen kann. Und was man mit ihnen machen kann, um sich das Leben zu erleichtern – beispielsweise skalar (also mit einer Zahl) addieren, um auf ein späteres Element zu zeigen.

Ganz toll ist auch die Multiplikation: Pointer ins Quadrat… da kann man sich schon mal die Maßeinheit überlegen.

Ist wohl leider an der Masse vorbeigegangen (okay, so sehr laut hat der Meister auch nicht geredet) – aber ich fands grandios 😀

Schulrechner zum Dritten

…aka the never ending story

Heute waren wir mal wieder planmäßig bei den Celeron-Ds, und zwar nicht um zu testen, ob alles geht, sondern um damit zu arbeiten. Was man arbeiten nennen kann… Auf jeden Fall ist es nicht wirklich ermutigend, wenn einen das BIOS gleich nach dem Einschalten und 3 minütigem Platten-Erkennen erst einmal rummäckert, dass das Übertakten (hallo? auf Schulrechnern!) fehlgeschlagen sei.

Na fein. Nachdem dann das Hochfahren doch noch über die Bühne gegangen ist, die nächste Überraschung: Neue Login-Kennungen fürs Netzwerk. Ganz großes Kino… Aber als wäre das nicht genug: Das Netzwerk ging, Gott preise Murphy, natürlich auch nicht.

Wenigstens sind die Rechner, außer dem Übertaktungsversuch soweit fehlerfrei hochgefahren, dass man damit arbeiten konnte – und die Ergebnisse zumindest bei Eigene Dateien ablegen konnte. Immerhin.

Neues von der Schulrechner-Front

…es ist seit Mittwoch letzter Woche nun eine Woche vergangen und die neuen Celeron Ds laufen angeblich jetzt fix. Nur das Internet funktioniert immer noch nicht.

Ende vom Lied: Heute wieder in dem Raum mit den Pentium-4s Unterricht. Und ich an dem Rechner mit der S3-Grafikkarte, die grad mal 256 Farben schafft. Jedoch war ich baff erstaunt, wie gut sie das Board darstellen kann 😀

Neue Schulrechner

…es war einmal, vor langer, langer Zeit…

… da hatte meine holde Schule eines der 2 Computer-Kabinette mit damals neuen Rechnern aufgerüstet. Das war Anfang 2001 und die Rechner waren Celerons mit 667 MHz, 64 MB RAM und Windows 2000.

Es wurde 2003 oder so und das bis dahin noch auf Pentium-1-Maschinen mit Windows 98 laufende Kabinett wurde mit Pentium-4-Systemen zu je 2 GHz und 256 MB RAM aufgerüstet.

Und das war dann auch der Stand der „Technik“ bis einschließlich letztes Schuljahr. Und – wie hätte es anders sein sollen – durften wir unsere informatischen Tätigkeiten an den 667-MHz-Rechnern ausüben, die selbstverständlich mit der Sache im Allgemeinen und im Besonderen total überfordert waren, heißt: Hochfahren dauerte rund 7 Minuten und ab dann ging der Auslagerungsmarathon los.

Nach harschem Protest seitens der Schüler und einem rührenden Einsatz des u.a. für mich zuständigen Info-Lehrers wurde versucht, das PC-Kabinett, welches als erstes damals aufgerüstet wurde, auf einen einigermaßen aktuellen Stand zu bringen. Nun habe ich keine Ahnung, ob die Rechner noch nicht ans Arbeiten gewöhnt worden, oder was da sonst falsch laufen könnte, auf jeden Fall ist das AsRock-Mainboard mit dem Dual-Core Celeron, den 512 MB DDR2-RAM und der OnBoard-Grafik (Kostenpunkt: 220 € pro Rechner, nur für den Fall, dass das jemanden interessiert) irgendwie ebenfalls total mit der Situation überfordert. Nach dem Anschalten brauchts erst einmal allein für den POST bald 3 Minuten (ohne, dass irgendetwas sichtbar wäre, dass sich etwas tut oder sonstiges), bevor überhaupt der Windows 2000’sche Ladebildschirm kommt. Nachdem recht fix selbiger auch wieder verschwunden ist, gehen weitere 10 Minuten ins Land – es klemmt an der Aktion „Computereinstellungen werden übernommen“, noch vor dem eigentlichen Login. Fairerweise bleibt zu sagen, dass NACH dem Login der Rest vom Hochfahren relativ fix geht… Jedoch funktioniert dann das Netzwerk, geschweige denn das Internet, nicht. Ich habe keine Ahnung, ob das alle neuen Rechner betrifft, auf jeden Fall hat es den betroffen, an dem ich normalerweise hätte sitzen sollen.
Alternativ hätte man *natürlich* auch den alten Rechnern einfach neuen Speicher gönnen können – das wäre mit ~30-50€/Rechner nicht bloß deutlich billiger gekommen, es wäre auch nicht so fehleranfällig gewesen. Die Rechenleistung reicht für unsere Zwecke nämlich auf jeden Fall aus und das schwächste Glied war, gut an der großen Auslagerungsdatei zu erkennen, definitiv der Speicher.

Bleibt zu hoffen, dass unsere zuständigen Admins das noch möglichst zeitnah in den Griff bekommen. Oder auch nicht, dann arbeiten wir halt, wie heute auch, an den 2003er Pentium-4-Maschinen weiter, so wie heute. Die haben wenigstens „ehrliche“ Power 😛

Sommerferien

Mein Gott… Da haben die Sommerferien gerade erst (am 20.07.) angefangen, und ich wusste schon heute nicht mehr, ohne nachzusehen, welcher Wochentag heute ist… Wo soll das nur hinführen?

Vielleicht liegt es aber auch an der meiner Ansicht nach vollkommen bekloppten Fusion[1] zwischen AMD und ATI.

Und die Weblog-Software hat auch irgendwie einen Schaden – die Verwaltungs-Startseite sah mir schon etwas komisch aus (naja, vllt lag das auch daran, dass ich schon ne ganze Weile nicht mehr drin war) – aber das Popup für Link einfügen funktioniert auch nicht mehr. Also es kommt zwar ein Popup, aber in dessen Kopfzeile steht nur eine Variable (für die Sprachvariablen) (da steht: „https://weblog.rellek.org – {$lang_insert_link_title}“) und der Inhalt bleibt weiß. Wer eine Lösung weiß, der breche bitte das Eis und verfasse einen aller ersten Kommentar zu einem Eintrag hier – vielen Dank schonmal 😀

///edit
Das Problem scheint im Firefox zu suchen zu sein :-/ Über die Javascript-Konsole spuckt er zumindest diese Meldung aus:

Fehler: [Exception… „‚Die Erlaubnis für das Lesen der Eigenschaft XULElement.accessKey wurde verweigert‘ when calling method: [nsIDOMXULLabelElement::accessKey]“ nsresult: „0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)“ location: „JS frame :: https://weblog.rellek.org/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20051211 :: anonymous :: line 41“ data: no]
Quelldatei: https://weblog.rellek.org/wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20051211
Zeile: 41

und mit Opera gibts gar keine Probleme… Schöne Sch…
Vielleicht wollte mich der Firefox auch nur daran erinnern, dass ich lieber die Beta 1 von der 2.0 probieren sollte…?

///edit2
Na sehr schön… Mit der Beta 1 vom FF2 geht zwar das dumme Popup wieder, dafür aber so gut wie keine Add-Ons. Es ist zum Heulen 🙁

[1] http://www.heise.de/newsticker/meldung/75826

FERIEN!

Seit heute 15 Uhr gehts hier etwas ruhiger zu – seit dem sind nämlich Ferien, Osterferien um genauer zu sein. Hab ich mir aber auch redlich verdient *g* Am Mittwoch noch die Geschichtsklausur und heute nicht nur die Physikklausur, nein, ich hab auch noch Chemie wiederbekommen. Ganze 2 Punkte 😀 (wer im Punktesystem noch nicht klarsieht: 2 Notenpunkte entsprechen einer glatten 5) – naja, jetzt steh ich auf 5,0 (nach altem System: eine glatte 4) und ich möcht sagen, solang das mindestens so bleibt oder sogar besser wird, bin ich zufrieden… In Chemie wird das sowieso nicht viel besser…

Aber von wegen „ruhiger“: Das Wochenende wird nicht ganz so ruhig, ich werde mich da einem – zugegebenermaßen etwas spätem – Artikel für GamePorts widmen müssen – es geht um einen Testbericht zu Ford Street Racing. So viel vielleicht schon vorab: Das Spiel an sich hat, im Vergleich mit anderen Rennspielen, versucht, etwas Neues zu erfinden (z.B. im Team fahren) – leider ist die Umsetzung des Ganzen nicht ganz so toll ausgefallen… Aber mehr dazu dann spätestens Freitag – das war ein Befehl vom Herrn Schäff – ich werd mir Mühe geben (müssen), dieses Ultimatum einhalten zu können. Aber ich glaube, das wird schon. Zu einem Freund von mir (was ich nicht alles hab, wa? :D) fahr ich erst irgendwann nächste Woche, weil bei meinem Fahrrad die Gangschaltung rumspinnt und irgendeine Klausur oder Leistungskontrolle habe ich wohl auch nicht zu befürchten *g* Also alles ganz easy 🙂